Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SQL Anywhere 11.0.1 » UltraLite - .NET Programming » Introduction to UltraLite.NET

 

System requirements and supported platforms

Development platforms

To develop applications using UltraLite.NET, you require the following:

  • A supported desktop version of Microsoft Windows.

  • Microsoft Visual Studio 2005 or Visual Studio 2008.

  • For Windows Mobile devices, .NET Compact Framework version 2 or later.

Target platforms

UltraLite.NET supports the following target platforms:

  • Microsoft .NET Compact Framework 2.0 and .NET Framework 2.0.

  • For Windows Mobile devices, Microsoft .NET Compact Framework version 2 or later.

  • Microsoft .NET Compact Framework version 2 or later on Windows.

In addition to your application code and the .NET Compact Framework, you must deploy the following files to your Windows Mobile device or computer running Windows:

  • iAnywhere.Data.UltraLite.dll   An assembly containing the iAnywhere.Data.UltraLite ADO.NET namespace. This file is required only if your application uses the iAnywhere.Data.UltraLite namespace.

  • iAnywhere.Data.UltraLite.resources.dll   The resources needed by the iAnywhere.Data.UltraLite ADO.NET namespace. This file is required only if your application uses the iAnywhere.Data.UltraLite namespace.

  • ulnet11.dll   This file contains the UltraLite runtime used by a single client. A separate version of the runtime is provided for each target platform.

  • ulnetclient11.dll   This file contains the interface to the UltraLite engine and is used to allow multiple clients to access the engine.

For details about UltraLite supported platforms, see [external link] http://www.sybase.com/detail?id=1002288.