Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SQL Anywhere 11.0.1 (中文) » SQL Anywhere 11 - 更改和升级 » 升级到 SQL Anywhere 11

 

升级 UltraLite

请务必先查看新功能和行为更改列表以确定应用程序是否受到影响,然后再在此版本软件中使用现有应用程序。请参见:

使用 UltraLite 11.0.0 实用程序

如果您的计算机上有多个版本的 SQL Anywhere,在使用 UltraLite 实用程序时必须注意系统路径,以确保所使用的是版本 11 的实用程序。请参见使用实用程序

升级版本 10 及更高版本数据库

对于版本 10.0.0 及更高版本的 UltraLite 数据库,当您从版本 11 应用程序或任何版本为 11 的 UltraLite 工具连接到数据库时,数据库文件格式会自动升级到版本 11。数据库一旦升级,就不能连接版本 10 的应用程序、实用程序和软件。请参见升级版本 10.0.0 或更高版本的 UltraLite 数据库

升级版本 9 及更早版本的数据库

对于版本 9 及更早版本的 UltraLite 数据库,必须重建数据库,具体方法是卸载旧的数据库,然后将其重装到新的版本 11 数据库。尝试连接版本 9 或更早版本的 UltraLite 11 数据库将导致数据库启动时发生错误。请参见升级版本 9 及更早版本的 UltraLite 数据库

与现有软件的兼容性
  • 版本 11 不支持 UltraLite for AppForge。

  • UltraLite 11.0.0 数据库文件只支持来自版本 11.0.0 客户端应用程序或版本 11 UltraLite 引擎的连接。

  • UltraLite 11.0.0 会自动升级版本 10 的数据库文件。

  • 对于使用版本 9 及更早版本的 UltraLite 所创建的数据库文件和应用程序代码,UltraLite 版本 11 运行时和 UltraLite 版本 11 引擎不起作用。

  • 从当前版本的 Sybase Central 对旧数据库和客户端应用程序进行的管理如下所示:

    • 对版本 11 的数据库进行完全管理。

    • 对版本 10 的数据库进行完全管理。版本 10 的数据库会自动升级到版本 11。

    • 只能连接到 8 或 9 版本的数据库来升级数据库文件格式。

Palm OS 的早期版本

Palm 设备的早期版本(例如,版本 4.x)只有大约 200 KB 的 RAM。由于 UltraLite 需要动态内存,此限制可能会引发问题。有关如何针对 UltraLite 优化这些早期版本的 Palm 设备的信息,请参见UltraLite 优化策略


升级版本 10.0.0 或更高版本的 UltraLite 数据库
升级版本 9 及更早版本的 UltraLite 数据库