Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SQL Anywhere 12.0.0 (Deutsch) » SQL Anywhere 12 - Änderungen und Upgrades » Upgrade von SQL Anywhere 12

 

Upgrade von SQL Remote

SQL Remote-Installationen umfassen eine konsolidierte Datenbank und viele entfernte Datenbanken sowie an jedem Standort einen SQL Remote-Nachrichtenagenten.

An jedem Standort verwaltet der SQL Remote-Nachrichtenagent das Senden und Empfangen von Nachrichten. Die Nachrichten haben die Form von SQL-Anweisungen, und der Datenbankserver wickelt die praktische Durchführung dieser SQL-Anweisungen ab.

Die Upgrade-Anforderungen für SQL Remote sind wie folgt:

  • Software-Upgrades können jeweils an einem Standort vorgenommen werden   Ältere Nachrichtenagenten (dbremote) können Nachrichten mit Nachrichtenagenten der Version 12 austauschen. Bei SQL Remote Version 5 können Nachrichtenagenten der Version 5 Nachrichten mit Nachrichtenagenten der Version 12 austauschen, wenn die compression-Datenbankoption auf -1 (minus Eins) gesetzt ist. Es besteht keine Notwendigkeit, ein Software-Upgrade in der gesamten Installation gleichzeitig durchzuführen. Siehe compression-Option [SQL Remote].

  • Datenbank-Upgrade durchführen   Wenn Sie ein Upgrade einer entfernten oder konsolidierten Datenbank vornehmen, die SQL Anywhere Version 9 oder früher verwendet, müssen Sie ein Upgrade des Datenbankdateiformats vornehmen, indem Sie Ihre Datenbank entladen und neu laden. Es besteht keine Notwendigkeit, ein Upgrade aller Datenbanken gleichzeitig vorzunehmen.

    Anweisungen zum Entladen und Neuladen der Datenbank finden Sie unter Datenbanken bis Version 9 für Version 12 neu erstellen.

  • Konsolidierte Adaptive Server Enterprise-Datenbanken umstellen   SQL Remote unterstützt keine konsolidierten Adaptive Server Enterprise-Datenbanken mehr. Um Adaptive Server Enterprise-Datenbanken zu synchronisieren, müssen Sie auf MobiLink umstellen.

    Weitere Hinweise zum Migrieren von SQL Remote zu MobiLink finden Sie unter [external link] http://www.sybase.com/detail?id=1034174#335.

  • Upgrade mit SQL Remote   Die Unterstützung für die Nachrichtensysteme VIM und MAPI für SQL Remote wurde in Version 11.0.0 entfernt. Wenn Sie eine Datenbank, die VIM oder MAPI verwendet, auf SQL Anywhere Version 12 umstellen, müssen Sie den Nachrichtentyp auf File, FTP oder SMTP ändern. Wenn der Nachrichtentyp MAPI oder VIM ist, kann dbremote.exe nicht gestartet werden.

 Beispiel