Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SQL Anywhere 12.0.1 » SQL Anywhere 服务器 - 编程 » 数据库和应用程序部署 » 嵌入式数据库应用程序部署

 

卸载版本 9 和更早数据库版本的支持部署

如果在应用程序中,要将版本 9.0 或较旧版本的数据库转换为当前版本格式,则除了需要使用数据库卸载实用程序 dbunload 外,您还需要以下附加文件:

说明 Windows Linux/Unix Mac OS X
对 10.0 之前的数据库的卸载支持 dbunlspt.exe dbunlspt dbunlspt
消息资源库 dbus[LL].dll dbus[LL].res dbus[LL].res
卸载脚本文件 optdeflt.sql optdeflt.sql optdeflt.sql
卸载脚本文件 opttemp.sql opttemp.sql opttemp.sql
卸载脚本文件 unloadold.sql unloadold.sql unloadold.sql

上表显示了带有标志 [LL] 的文件。这表示消息文件有多个,每个消息文件支持不同的语言。如果要安装对不同语言的支持,必须添加这些语言的资源文件。消息文件如下所示。

 Windows 消息文件
 Linux 消息文件