Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SAP Sybase SQL Anywhere 16.0 » SQL Anywhere 16 - Changes and Upgrading » How to upgrade to SQL Anywhere 16 » MobiLink upgrades » Consolidated database upgrades


Upgrading a consolidated database (SQL Anywhere 10.0.0 and later)

Before you can use the new MobiLink server with an existing SQL Anywhere consolidated database that is version 10.0.0 or later, run upgrade scripts to install new system objects.


You must be the owner of the currently installed MobiLink system tables to run the setup scripts.

The MONITOR system privilege is required to invoke the locking/blocking detection logic.

Contexte et remarques

You can also use the following methods to update the MobiLink system setup:

  • In the MobiLink plug-in for Sybase Central, click MobiLink 16 » Project » Consolidated Databases and right-click the database name and click Check MobiLink System Setup. If your database requires setup or upgrading, you are prompted to continue.

  • When you use the Deploy Synchronization Model Wizard, system setup is checked when you connect to your consolidated database. If your database requires setup or upgrading, you are prompted to continue. See Synchronization models.

  1. Upgrade the SQL Anywhere software.

    See Upgrading version 10 and later databases.

  2. Upgrade the MobiLink system setup by running the appropriate upgrade script for the version you are upgrading from.

    The upgrade script is called upgrade_sa.sql. It is located under your SQL Anywhere installation in MobiLink\upgrade\version, where version is the SQL Anywhere version you are upgrading from.

    For example, connect to the database in Interactive SQL and execute the following statement:

    READ "C:\Program Files\SQL Anywhere 16\MobiLink\upgrade\10.0.x\upgrade_sa.sql"


The consolidated database can now be used with the new MobiLink server.