Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SAP Sybase SQL Anywhere 16.0 » SQL Anywhere 16 - Changes and Upgrading » How to upgrade to SQL Anywhere 16


SQL Remote upgrades

SQL Remote installations include a consolidated database and many remote databases, together with a SQL Remote Message Agent at each site.

At each site, the SQL Remote Message Agent handles the sending and receiving of messages. The messages take the form of SQL statements, and the database server handles the actual execution of those SQL statements.

The upgrade requirements for SQL Remote are as follows:

  • Software upgrades can be one site at a time   Older Message Agents (dbremote) can exchange messages with version 16 Message Agents. For version 5 of SQL Remote, the version 5 Message Agents can exchange messages with version 16 Message Agents, as long as the compression database option is set to a value of -1. There is no need to upgrade software throughout the installation simultaneously. See compression option [SQL Remote].

  • Upgrade databases   If you are upgrading a remote or consolidated database that used SQL Anywhere version 9 or lower, you must upgrade the database file format by unloading and reloading your database. There is no need for all databases to be upgraded at the same time.

    For instructions on unloading and reloading the database, see The rebuild process for version 9 and earlier databases.

  • Upgrading Adaptive Server Enterprise consolidated databases   SQL Remote no longer supports Adaptive Server Enterprise consolidated databases. To synchronize Adaptive Server Enterprise databases, you should upgrade to MobiLink.

    For information about migrating from SQL Remote to MobiLink, see [external link]

  • Upgrading with SQL Remote   Support for the VIM and MAPI message systems for SQL Remote was removed in version 11.0.0. When you upgrade a database that uses VIM or MAPI to SQL Anywhere version 16, you must change the message type to File, FTP, or SMTP. If the message type is MAPI or VIM, dbremote.exe does not start.