Click here to view and discuss this page in DocCommentXchange. In the future, you will be sent there automatically.

SAP Sybase SQL Anywhere 16.0 (中文) » SQL Anywhere 16 - 更改和升级 » 如何升级到 SQL Anywhere 16

 

SQL Remote 升级

SQL Remote 安装包括一个统一数据库和许多远程数据库,以及每个站点上的 SQL Remote 消息代理。

在每个站点上,SQL Remote 消息代理处理消息的发送和接收。消息采用 SQL 语句的形式,数据库服务器处理这些 SQL 语句的实际执行。

SQL Remote 的升级要求如下:

  • 可以逐个站点进行软件升级   较低版本的消息代理 (dbremote) 可以同版本 16 的消息代理交换消息。只要将数据库选项 compression 的值设置为 -1,SQL Remote 版本 5 消息代理就可以与版本 16 消息代理交换消息。无需在安装期间同时升级软件。请参见compression 选项 [SQL Remote]

  • 升级数据库   如果要升级使用 SQL Anywhere 版本 9 或更低版本的远程数据库或统一数据库,必须通过卸载然后再重装数据库的方式升级数据库的文件格式。无需同时升级所有数据库。

    有关卸载和重装数据库的说明,请参见9 版及更早版本数据库的重建过程

  • 升级 Adaptive Server Enterprise 统一数据库   SQL Remote 不再支持 Adaptive Server Enterprise 统一数据库。要同步 Adaptive Server Enterprise 数据库,应升级到 MobiLink。

    有关从 SQL Remote 迁移到 MobiLink 的信息,请参见 [external link] http://www.sybase.com/detail?id=1034174

  • 升级 SQL Remote   版本 11.0.0 中删除了 SQL Remote 对 VIM 和 MAPI 消息系统的支持。将使用 VIM 或 MAPI 的数据库升级到 SQL Anywhere 16 版时,必须将消息类型更改成 File、FTP 或 SMTP。如果消息类型是 MAPI 或 VIM,则 dbremote.exe 不会启动。

 示例